lunes, 23 de septiembre de 2013

Creador de passwords aleatorios Excel sin funciones.

Crearemos contraseñas aleatorias utilizando letras desde [A-Z] números entre [0-9] y letras entre [a-z] con

6 lugares o caracteres. Donde:
la posición 1 corresponde a [A-Z]
la posición 2 corresponde a [a-z]
la posición 3 corresponde a [0-9]

Crear desde una hoja de Excel una lista desde A1 hasta A122
extender la formula =caracter(A1) desde B1 hasta A122
utilizaremos la formula =SI(ALEATORIO.ENTRE(1;3)=1;CARACTER(ALEATORIO.ENTRE(65;90));SI(ALEATORIO.ENTRE(2;3)=2;CARACTER(ALEATORIO.ENTRE(97;122));CARACTER(ALEATORIO.ENTRE(48;57))))

desde la celda C1, copiandola hasta la celda H1

por último en la celda I1 usamos
=C1&D1&E1&F1&G1&H1
para concatenar los caracteres aleatorios que hemos generado.

Espero que esto les sea de utilidad y no olviden comentar...

Saludos.

3 comentarios:

  1. NO PUEDO, intento e intento y no paso de:
    "Crear desde una hoja de Excel una lista desde A1 hasta A122
    extender la formula =caracter(A1) desde B1 hasta A122"

    Sabes yo necesito crear usuarios del tipo "cvcvcvnn" (c=consonante, v=vocal, n=numero) ejemplo "coneku34" pero no puedo hacerlo en excel, crees que hay una forma, si es asi puedes decirme como y sino es mucho pedir puedes regalarme esta formula ya hecha.
    GRACIASSS....

    ResponderEliminar
  2. Excelente!!!!

    Otra opción sería tu misma fórmula concatenada las veces cuantos caracteres querras que tenga la contraseña creada, o sea si querés una contraseña de 4 caracteres entonces (obviamente respetando los límites de contenido):

    =SI(ALEATORIO.ENTRE(1;3)=1;CARACTER(ALEATORIO.ENTRE(65;90));SI(ALEATORIO.ENTRE(2;3)=2;CARACTER(ALEATORIO.ENTRE(97;122));CARACTER(ALEATORIO.ENTRE(48;57))))&SI(ALEATORIO.ENTRE(1;3)=1;CARACTER(ALEATORIO.ENTRE(65;90));SI(ALEATORIO.ENTRE(2;3)=2;CARACTER(ALEATORIO.ENTRE(97;122));CARACTER(ALEATORIO.ENTRE(48;57))))&SI(ALEATORIO.ENTRE(1;3)=1;CARACTER(ALEATORIO.ENTRE(65;90));SI(ALEATORIO.ENTRE(2;3)=2;CARACTER(ALEATORIO.ENTRE(97;122));CARACTER(ALEATORIO.ENTRE(48;57))))&SI(ALEATORIO.ENTRE(1;3)=1;CARACTER(ALEATORIO.ENTRE(65;90));SI(ALEATORIO.ENTRE(2;3)=2;CARACTER(ALEATORIO.ENTRE(97;122));CARACTER(ALEATORIO.ENTRE(48;57))))

    ResponderEliminar